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1 Summary  
 
The goals of this guide are to help reviewers with the following: 
 

1. Understand the Model 
 
A reviewer needs to understand how to use TreeAge Pro to explore the model structure 
and to find the important information. 
 

2. Reproduce Results 
 
A reviewer needs to be able to reproduce the results submitted by a modeller.  
 

3. Test Values/Assumptions 
 
A reviewer may want to test the model by changing parameter values and assumptions.  
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2 Orientation 
 

2.1 Information Expected From the Modeller 
 
A reviewer should expect a modeller to provide the following information with their model. We 

call it the “list of 5”. 

1. Purpose of the model 

2. Strategies in the model  

3. Outcomes measured by the model 

4. Analyses to be run 

5. Important outputs to consider 

We encourage reviewers to request the above information for any model submitted. However, if 

this information is not provided, it is sometimes possible to retrieve some of this information 

directly from the model. More details about this can be found in section 3, Understand the 

Model.  

 

Model files are opened like any document files. A TreeAge Pro model usually has the file 

extension “.trex”. The most obvious ways to open models are either using the File menu in the 

software to select the model to open, or by selecting the model file directly and opening via 

double-click. There may be other files which are associated with the model, and these should be 

saved into the same folder. For example, a model may contain links to an Excel document. In 

this case, if the Excel file is saved in the same folder as the model, TreeAge will update the 

connections between the associated files.  

 

2.2 Navigating the TreeAge Pro User Interface 

For users are who unfamiliar with the TreeAge Pro interface, this section gives you some basics 

to assist you. Figure 1 shows the Analyze Perspective or Layout and includes notes to highlight 

features of the interface. You may find these things particularly useful:  

 The TreeAge Pro workbench is organized into panes which can be resized, maximised and 

minimised as desired to use the space most effectively for any task (Figure 2a). 

 Layouts (Build, Analyze, Advanced and Simple at top right of the window) present the 

software components in different ways. We recommend that you use the Analyze layout 

when reviewing models.  

 As you adjust your workbench by resizing panes and opening/closing views, TreeAge 

Pro will remember the current layout. To return to the original organization of the layout, 

right click on the layout button (at the top right hand side) and choose Reset from the 

context menu. 
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Figure 1: Analyze layout with important components highlighted.  
The Model Overview View is opened from the Views menu. 

 

2.2.1 Components of the TreeAge Pro interface 

The following Views are useful and open in the Analyze perspective: 

 Tree Diagram Editor: 

o Edit/review model structure. 

o Contains the palette which is used to add nodes and labels. Hide the palette using 

the arrow at the top of the window (Figure 2a, # 1).  

o When analysis output is generated, those results will be presented as additional tabs 

within this pane. 

 Model Value Views: 

o Views for specific values in the model, including variables, distributions, tables, 

trackers, Markov and Discrete Event Simulation (DES) information. 

 Electronic Help: 

o Contains a “User Guide” for TreeAge Pro. 

o Other “helper views”… 

 Console – can be used to output calculations during analyses. 

 Evaluator – acts like a calculator to test expressions with the context of the 

selected node. 
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 Projects View – access files from projects, which act as pointers to file folders 

with TreeAge Pro files (not necessary to use this). 

Views which are not open in the Analyze perspective which can be useful include: 

 Model Overview: 

o See entire model structure in compact format and use it to navigate around a large 

model. This View is opened via Views menu and visible in Figure 1. 
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2.2.2 Using the TreeAge Pro interface (Quick start) 

 To quickly maximize an Editor or View, double-click on its tab. Then double-click on it again 

to return it to its prior location (Figure 2a, # 2). 

 Open and/or activate any View via the Views list in the toolbar.  

 Most of the Views have a common toolbar and the functions are highlighted in Figure 2b. 

 The Analyze perspective has a toolbar of most commonly used analysis functions. Figure 2c 

highlights the elements of the toolbar which are available when a model is in the Tree Editor 

window. The toolbar will change dependent on content of the Editor (i.e. model, graph or 

text output). By rolling over the toolbar, tooltips describe the function of each icon. 

 Any of the Views (other than the Tree Editor) can be detached from the software window to 

more easily work with the model. Select the tab at the top of the View, right click and select 

Detach from the menu (Figure 2a, #3). The window will then be floating and can be moved. 

Repeat the process to re-attach. 

 All of the individual panes in the software can be re-sized by selecting the area between 
them  (hove mouse over and wait until a double arrow appears) and then dragging (by 
holding the left mouse key) to re-size (Figure 2a, # 4).  

 The Dashboard View gives an overview of the most important elements of the model. Open 
the Dashboard from the Views list in the toolbar (Figure 2a, #8). 

 

Figure 2a: Guide to find useful functions in the TreeAge Pro interface 
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Figure 2b: Toolbar guide highlighting functions common to most Views 

 

Figure 2c: Toolbar guide highlighting common functions in the Analyze perspective 

  



A Guide to Reviewing TreeAge Pro Models 

8 
©TreeAge Software Inc 2015       Version 2015.2.0 

3 Understand the Model 

This section is designed to help a reviewer understand how a model is structured and where to 

find the model parameters and calculated values in TreeAge Pro.  

3.1 Identify model purpose and outcome measures 

 The Dashboard View (as in Figure 3a) provides an “at-a-glance” overview to all the elements 

of the model and can help identify model purpose and outcomes. The View is split into three 

sections: 

1. Model Properties – Provides information about the model configuration, including the 

calculation method. Suggests how to analyse the model (cohort or microsimulation) and 

indicates whether there are any linked workbooks. 

2. Model Structure/Display – Provides information about the number of Decision, Markov 

and DES nodes as well as clones. Indicates if the model is set to hide or display 

important information such as displaying variables, notes, Markov/DES info and clones 

with toggle option to change these settings. 

3. Model Inputs – Provides information about the number and location of Variables, 

Variable Definitions, Distributions, Tables and Trackers in the model. 

 Examining the node labels at the root decision node and its branches can be helpful. The 

root decision node label will often describe the basic question the model is trying to address. 

Branches off the decision node represent alternative treatment strategies. Normally, each 

strategy node will be described by its node label (Figure 3b). 
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Figure 3a: Healthcare decision model with Dashboard View expanded to show Model 
Properties, Model Structure/Display and Model Inputs. 

 
 
 

 

Figure 3b:  Healthcare decision model showing node labels 
 



A Guide to Reviewing TreeAge Pro Models 

10 
©TreeAge Software Inc 2015       Version 2015.2.0 

 Outcomes measured can be partially determined by the model’s calculation method. You 

can access the calculation method by selecting Tree > Tree Preferences from the menu, 

then choose the category Calculation > Calculation Method (Figure 4). Or you can use the 

Dashboard to observe the Calculation Method. 

 

Figure 4: Tree Preferences dialogue 

 A calculation method of cost-effectiveness indicates that treatments should be evaluated on 

the basis of Cost-Effectiveness Analysis (CEA), which requires separate payoff sets to be 

used for cost and effectiveness. Cost is nearly always measured in units of currency, and 

effectiveness is often, but not always measured in Quality Adjusted Life Years (QALYs).  

 To find the units for Cost and QALYs, look for any Numeric Formatting used by the modeller; 

select Tree > Tree Preferences > Calculation > Numeric Formatting and look for the units 

labelling outputs (Figure 5a). A modeller may use custom payoff names which can be found 

in Tree Preferences > Calculation > Payoffs > Custom Names. This can be very helpful 

when non-standard outcomes are used (Figure 5b). 

 The Configure Model Wizard is accessible via the toolbar (Figure 2a, # 9). This can be used 

to access the most commonly accessed Tree Preferences. The Configure Model Wizard will 

walk you through:  

o Calculation Method;  

o Payoffs (active and extra);  

o Global discounting;  

o Custom payoff names; and  

o Numeric Formatting.   

 All Tree Preferences can be accessed via the Tree > Tree Preferences menu, or by 

selecting the Tree Preferences icon in the toolbar (Figure 2a, # 10).  
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Figure 5a: Numeric Formatting to 
set units in payoffs 

 

Figure 5b: Enabled payoffs with custom 
names

 It is difficult to know which analyses should be run without some guidance from the 

modeller. An important question is whether analyses can be run at the overall cohort level or 

if the model requires patient-level simulation. If the model contains trackers (refer to Section 

3.6 Trackers) and/or distributions with “per trial sampling” (refer to Section 3.5 Distributions), 

it is very likely that patient-level simulation is required. The Dashboard uses these as 

indicators that the model likely requires patient-level simulation. Note that this requirement 

affects all other analyses, including CEA and all sensitivity analyses.  

3.2 Look for model documentation 

 The modeller should provide the “list of 5” as a minimum. 

 Model documentation (if created by modeller) may be either be: 

o Available as a HTML file which came with the original model file, or 

o Accessed by clicking in the Tree Diagram Editor and pressing the F1 key. 

o Alternatively, a modeller can provide the “list of 5” information in a separate 

document. 

 Within most views, there are places for the modeller to enter comments and descriptions for 

variables and other model inputs.  

 Notes can be used to document any model by selecting the Notes icon in the Tree Diagram 

Editor palette, and then drag/dropping a Note into the editor (Figure 2a, # 5). Notes can 
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optionally be bound to a node to highlight that area of the model. The modeller may have 

already added notes as a guide, but you can also add notes as you choose.  

 

3.3 Examine the model structure  

 Maximize the Model Overview window to see the entire model structure, double click on the 

tab to increase and then decrease (Figure 2a, # 6).  

 In the Tree Editor window, use the palette to zoom in and out via the “+” and “-“ (Figure 2a, # 

7). To stop zooming in/out, click on the selection arrow at the top of the palette.  

 You can change the Tree Preferences to hide the numeric values displayed within the model 

structure. This can make it easier to examine the model structure (Figure 6). 

o Choose Tree > Tree Preferences from the menu. 

o Select category Display > Variables/Markov Info >  Hide definitions. 

o Select category Display > Node Text/Comments>  Hide probabilities. 

o Remember to select “Show definitions” in the Variable/Markov Info to examine model 

details closely as this will assist with identifying where variables are being defined 

throughout the model. 

o Note that using the Dashboard you can access and turn on/off elements of the model 

structure listed above via the Model Structure/Display section. 
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      Figure 6: Hiding definitions and probabilities via Tree Preferences  
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 Look for Markov and DES nodes within the overall model structure, Figure 7a and b. 

o Markov structure will look like (Figure 7a)..… 

 Markov node (purple circle with “M”) is the start of a Markov Model. The model 

time horizon is defined here. 

 Each direct branch from the Markov node is a Health State. 

 All structure to the right of each Health State is a Transition Subtree. Each 

Transition Subtree describes the events that can occur if starting a cycle in a 

specific Health State. Each end point within the Transition Subtree is a terminal 

node which sends flow back to a Health State to start the next cycle. 

 Values (cost, eff, etc.) can be accumulated at any Health State and at any event 

in a Transition Subtree. 

 

Figure 7a: Markov model structure 
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o DES structure will look like (Figure 7b)…. 

 DES node (purple circle with “D”) is the start the DES model. The model time 

horizon is defined here. 

 Time nodes anywhere to the right of the DES node represent a point where a 

“trial” (or individual) is waiting for the next event. Time-based values are 

accumulated here. 

 Branches of time nodes represent each possible event with the time to event 

beneath each node. Event-based values are normally accumulated here. 

 Time is automatically updated based on the appropriate time-to-event. 

 

Figure 7b: DES model structure 

o Select any node and use the Subtree menu to collapse/expand subtrees to better 

examine certain portions of the model.  
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3.4 Variables 

 Examine variables via the Variable Properties View (Figure 8).  

 Modellers may group variables into logical Categories. 

 Look for key parameters (root node definition is a number). 

 Look for key formulas (root node definition is a formula expression). 

 Look for variable definitions in the model that are not placed at the root node. Such variable 

definitions may be used to apply different values to the same variable name in different parts 

of the model. 

o This is useful for Clones where we want variables to have different values dependent 
on where they are in the tree. 

o The Variable Definitions View will show different variable definitions based on the 
node selected in the Tree Diagram Editor (Figure 11). 

 

Figure 8: Variable Properties View 
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3.5 Distributions 

 Examine distributions via the Distributions View (Figure 9). 

 The distribution list will include the name (as given by the modeller), distribution type and 

sampling rate. 

o Distributions with sampling rate “Sample per EV (Expected Value)” are likely 

parameters for Probabilistic Sensitivity Analysis. 

o Distributions with sample rate “Sample per Trial” are likely individual characteristics 

for patient-level simulation. Any such distributions suggest a heterogeneous cohort; 

therefore, the model should most likely be analysed via Microsimulation. 

 Double-click on a distribution to edit its properties via the Add/Change Distributions 

dialogue, including adding Comments and changing the distribution’s parameters and 

sampling rate (Figure 9). 

 

Figure 9: Distributions View and Add/Change Distribution dialog  

 



A Guide to Reviewing TreeAge Pro Models 

18 
©TreeAge Software Inc 2015       Version 2015.2.0 

3.6 Trackers 

 Examine trackers using the Tracker Properties View. 

o The Dashboard will indicate if there are Trackers in the model. Additionally, if there 

are no trackers in the model, then the Tracker View will be blank.  

 Trackers are used to record individual patient data values, usually in response to a specific 

event. The information stored in a tracker can impact any subsequent value in the model. 

 In order to collect the individual-level data via trackers, the model must be analysed via 

Microsimulation. 

 Trackers usually indicate that a model must be analyzed via patient-level simulation. 

 

3.7 Clones 

 Clones allow modellers to reuse portions of model structure (the “clone master”) in other 

parts of the model (the “clone copy”).  Clone copies are synchronized with the clone master, 

guaranteeing consistency in model structure and eliminating the need to recreate portions of 

the model (Figure 10). 

 

 

Figure 10: Clone master and copies in the tree editor and information in the Clones View 
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 All Clones will appear in the Clone Masters/Copies View. This view lists all the clone 

masters to the left. When a clone master is selected, all the clone copies associated with 

that clone master are listed to the right. Select a clone master or copy and then click the 

yellow arrow in the view’s toolbar to “go to” the node associated with the clone within the 

Tree Editor. 

 In the Tree Editor, clones are presented as follows: 

o Clone master anchors are marked by a heavy solid line. The clone master contains 

the subtree to the right of the anchor node (but not the anchor node itself). The clone 

master index is presented beneath the node marker of the anchor node. 

o Clone copies can either be displayed or hidden based on a Tree Preference option. 

Specifically, within the category Display > Tree Editing/Layout, check or uncheck the 

option “Show clone copy subtrees”. 

 When not displayed (as in Figure 10), the clone copy will reference the clone 

master by index and name. 

 When shown, the clone copy structure is displayed with grey node lines to 

indicate that the structure cannot be edited. 
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 Clone masters and copies will always use the same variable references; however, the 

variables may use different variable definitions. This allows modellers to pass different 

values into the clone master vs. its clone copies. 

o Variables which are associated with a specific clone master or copy are frequently 

defined just to the left of the clone master and copies. Figure 11 shows where a 

common variable has different values in the clone master and the clone copy. We 

can see two places to look for variables defined at specific nodes:  

o Under the node in the Tree Editor and in the Variable Definitions View.  

 

Figure 11: Tree Editor, Variable Properties and Variables Definitions Views illustrating 
how different variables are defined differently at each node 
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3.8 Model Validation 

 The Model Validation View allows you to perform a series of validation checks on the model. 

This will alert you of common model errors. In the Model Validation View, click the “play” 

button to see any modelling irregularities found (Figure 12), such as scenarios not 

terminated, missing probabilities and unused variables. Model Validation cannot validate the 

data used in the model. 

 

 

Figure 12: Validator view showing location of the errors in the tree editor window 
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3.9 Find, Search, and Replace 

 Choose Tree > Find from the menu to search for words or expressions in the model. 

TreeAge Pro allows you to select the contexts (variables, node labels, etc.) which you wish 

to search. 

 When the search is finished, the results open in a Search View (Figure 13), which allows 

you to select and/or replace each result as you wish. . When a specific search result is 

selected, it is also highlighted in the Tree Editor.  
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Figure 13: The search results in the Search View and highlighted in the Tree Editor 
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4 Reproduce Results 

This section provides an overview of how to run some of the most common analyses to 

reproduce the results submitted by the modeller. Note that it may not be possible to run all these 

analyses on one model and the “list of 5” should direct you to those analyses which are 

appropriate.  

All analyses can be executed from the Analysis menu, Figure 14. Tree Preferences impact the 

way the analyses are calculated, the most important being the model’s Calculation Method. 

 

Figure 14: Analysis menu 

In addition, some of the most common analyses can be executed from the tool bar when the 
Analyze perspective is selected. Refer to Figure 2c for a description of the analyses you can run 
from the toolbar. We will describe how to find the analysis functions using the menus in the 
remainder of this document, but the toolbar can also be used.  
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4.1 Cost-Effectiveness Analysis (CEA) 

 Use to compare strategies on the basis of cost-effectiveness.  

 Select the decision node where CEA should be run. This is usually the left most node in the 

model.  

 Choose Analysis > Rankings from the Analysis menu to generate a text report which will 

provide the overall expected values for each strategy, along with incremental values. The 

details include cost, effectiveness, incremental cost-effectiveness ratio (ICER), net monetary 

benefits (NMB) and dominance (if appropriate) (Figure 15).  

 

 

Figure 15: Cost Effectiveness Rankings  
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 Choose Analysis > Cost-Effectiveness from the menu to generate the CEA graph, with 

options to generate the Rankings report and insert a Willingness-To-Pay (WTP) line (Figure 

16).  

 
 

Figure 16: Cost Effectiveness Analysis graph showing options to generate 
secondary reports and edit the graph 

 If a model requires Microsimulation, you must first run Microsimulation first, then use the 

aggregated results to compare strategies, including CEA. Do not directly choose Analysis > 

Cost Effectiveness from the menu. See Section 5 below for more details about 

Microsimulation.  
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4.2 Sensitivity Analysis (One-way) 

 Use to study the impact of uncertainty related to a single parameter across a range.  

 Select the decision node.  

 Choose Analysis > Sensitivity Analysis > 1-way from the menu and a dialogue box, shown in 

Figure 17, will appear to prompt the user to select the variable parameter and set its 

sensitivity analysis range.  

 

Figure 17: Dialogue for entering details for 1-way sensitivity analysis 

 
 Click the variable column to activate the dropdown menu and select a variable. Then, set 

the range and number of intervals. 

o Be sure to choose only variables that are used for numeric parameters and not 

variables that are defined using formula expressions. 
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 The aggregated output is a set of Rankings, which compare strategies at each parameter 

value within the uncertainty range (Figure 18). 

 Secondary outputs can be useful when looking for thresholds where the recommended 

strategy changes. Specifically, you might choose the “x versus ICER” and “Net Benefits” 

graphs which are highlighted in Figure 18. 

 If the model requires Microsimulation, check the appropriate box when running one-way 

sensitivity analysis, as indicated in Figure 17.  

 

Figure 18: One-way sensitivity analysis output 
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4.3 Probabilistic Sensitivity Analysis (PSA) 

 Use to study the impact of combined uncertainty related to a number of parameters 

represented by distributions.  

 Select the decision node.  

 If the model does not require Microsimulation: 

o Choose Analysis > Monte Carlo Simulation > Sampling (Probabilistic Sensitivity)… 

from the menu. 

o Select the number of samples to run, as in Figure 19 except with “Run 1st-order 

trials” unchecked. 

o Note that the Expected Value (EV) for each set of sampled parameters is generated 

from a cohort-level analysis. 

 If the model requires Microsimulation: 

o Choose Analysis > Monte Carlo Simulation > Samples & Trials… from the menu. 

o Select the number of samples and trials to run, as in Figure 19.  

o Note that the expected value for each set of sampled parameters is generated from 

the aggregated mean values from a set of trial results. 

 

Figure 19: The dialogue for entering number of Samples and Trials for running 
PSA with Microsimulation  

 The number of samples and trials to run: 

o The modeller should provide this advice based on research. 

o Generally for samples, the more distributions being sampled from, the more samples 

should be taken. You can start with 1,000 samples, but may need more to stabilise 

results. 

o Generally for trials, a sufficient number need to be run through the model to stabilise 

the aggregate results. This should be tested prior to running PSA to ensure the 

number of trials in the microsimulation is generating stable results. You can start with 

10,000 trials, but you may need more.  
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 To cancel a simulation which is in progress, use the “cancel” button in the dialogue box 

which appears when the simulation is running. 

 PSA will sample those distributions which have been created with a sampling rate of 

“Sample per EV”.  

 The outputs from PSA are usually Expected Cost and Effectiveness and the analysis 

provides statistics around those values.  

 Secondary outputs are listed to the right of the aggregated values. They include several text 

reports and charts (Figure 20). Key secondary reports are… 

o Text Report > Values, Dists, Trackers – a numeric display of the iteration-by-iteration 

data generated by the analysis. 

o Charts > Scatterplots > ICE Scatterplot – plots incremental cost versus incremental 

effectiveness when comparing two strategies (Figure 21). 

o Charts > Acceptability > Acceptability Curve – plots the percentage of iterations 

favouring each strategy as WTP changes (Figure 22). 

 

Figure 20: The simulation output with secondary reports listed for PSA with 
Microsimulation 
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Figure 21: ICE Scatterplot from PSA with Microsimulation 

 

Figure 22: Acceptability Curve as WTP changes from PSA with Microsimulation 
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4.4 Markov Cohort Analysis 

 Use to show the detailed calculations performed when evaluating a Markov model via cohort 

analysis. This analysis is run for a single Markov model within the overall decision tree.  

 Select a Markov node, then choose Analysis > Markov Cohort (quick) or Markov Cohort (full) 

from the menu, as in Figure 14. 

o The “quick” output shows the states and value accumulated by cycle (Figure 23). 

o The “full” output expands on the quick output by showing the progression of the 

cohort from each state through its entire transition subtree. 

 

Figure 23: Markov Cohort Analysis (quick) output 

 This output is useful for validating that a Markov model is producing the results which are 

expected, prior to incorporating those results into a larger model. 
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 To the right of the Markov output, secondary reports graphs are available, including a 

survival curve (Figure 24). 

 

Figure 24: Survival curve: one of the secondary outputs of Markov analysis 

 If a model requires Microsimulation, Markov Cohort Analysis should not be used. 

Microsimulation Markov models are evaluated based on individual-patient simulation rather 

than overall cohort aggregation.  



A Guide to Reviewing TreeAge Pro Models 

34 
©TreeAge Software Inc 2015       Version 2015.2.0 

4.5 Microsimulation 

 Use to generate primary analysis results for models that require individual-patient 

simulation.  

 Select the decision node, then choose Analysis > Monte Carlo Simulation > Trials from the 

menu. 

 Set the number of trials required. 

o Note that the more complex the model, the more trials need to be run to stabilize 

aggregate results. 

 Outputs are aggregated EV’s for cost and effectiveness for all trials. Statistics around the 

values are provided. 

 Secondary outputs to the right of the aggregated values include several text reports and 

charts, Figure 25. Key secondary reports are… 

o Text Report > Values, Dists, Trackers – a numeric display of the iteration-by-iteration 

data generated by the analysis. 

o Graph > CE Analysis > CE Graph and/or CE Rankings – displays the cost-

effectiveness analysis as in Section 1 where we considered CEA (Figures 15 and 

16). Note that for models that require Microsimulation, this is the primary analysis for 

comparing strategies. 

 

Figure 25: Microsimulation output with Expected Values and statistics for Cost 
and Effectiveness. The Action menus show where to generate key outputs. 
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4.6 Analysis Seeding 

 Seed the random number generator to yield consistent output from any Monte Carlo 

simulation analysis, which includes PSA and Microsimulation. 

o Note that use of seeding can hide a problem of running too few trials to stabilize 

aggregate results. 

 To set the seed, go to Tree > Tree Preferences > Analysis Settings > Monte Carlo Options > 

Random Number Seeding. 

 

4.7 Analysis Considerations 

In all analyses, important considerations are: 

 Are there specific parameters that are good candidates for 1-way sensitivity analysis? 

 If some distributions are defined with a Sampling Rate of “Sample per EV”, run PSA. 

 If not a Microsimulation model, run Markov Cohort Analysis at specific Markov nodes as 

desired. 

 These details about types of analyses to run should be provided in the “list of 5”. 

  



A Guide to Reviewing TreeAge Pro Models 

36 
©TreeAge Software Inc 2015       Version 2015.2.0 

5 Testing Values/Assumptions 

This section provides details to the Reviewer about how to test the model to generate sets of 

results, other than those provided by the modeller. There are a number of ways that changing 

the model might be of interest to the Reviewer. 

5.1 Change the values of key variables in the model and repeat 
analyses 

 Most parameter variables can be changed via the Variable Properties View. If no definition 

exists at the root node, you probably should not add one.  

 Figure 26 shows the editor which opens once you have selected the variable to change and 

clicked the pencil in the Views tool bar. 

 The Add/Change window provides the options of editing an “Expression”. 

o The expression can be a number, entered directly into the “expression” field; 

o The expression can be a formula, entered directly into the “expression” field with 

elements via the formula editor by selecting individual model elements (variables, 

functions, etc.) to build the expression. 

 

Figure 26: Add/Change Variable dialogue at the root node 
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5.2 Change the parameters describing key distributions in the model 

 In the Distributions View, Distributions in the model can be open by highlighting them and 

selecting the pencil in the view tool bar.  

 Distributions can then be edited by changing the distribution parameters, see Figure 9. 

 Dependent on the Resample rate for the distribution, the effect of changing the distribution 

maybe seen through different analysis.  

o Sample per EV will affect any PSA analysis. 

o Sample per Trial will affect any microsimulation analysis.  

5.3 Testing uncertainty around variables in the model  

 If distributions with a Resample rate per EV have been changed, then this will affect PSA. A 

count of distributions by sampling rate is available in the Dashboard View. 

 In addition, testing uncertainty can also be done as per the instructions in the section for 

reproducing results for 1-way sensitivity analysis and PSA. 

5.4 Restrict which strategies to run 

 You may wish to select which strategies to include in analyses. You can exclude strategies 

from analyses using the instructions below. 

o Select a branch/strategy which starts at the root decision node.  

o Right click and a menu will give you the option of “Excluding the Strategy from 

Analysis”. Once a strategy is excluded, the strategy branch will appear with a double 

strike the branch to indicate it is excluded from analysis (Figure 27). 

 

When the model is rolled-back, the preferred strategy will be highlighted in green with the other 

strategies highlighted in red.  

 

Figure 27: Excluding a Strategy from Analysis 
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6 Contact Us  

If you have additional questions, please contact support@treeage.com or call (+1) 413 458 
0104. 

mailto:support@treeage.com

